Could not renew your HMRC authorisation

Scenario

You may see the following error message when your authorisation from HMRC to use Onvio for Making Tax Digital (MTD) submissions has expired.

Error message

We could not renew your HMRC authorisation. Please reauthorise.

Cause

When HMRC authorises software such as Onvio for MTD, the authorisation is valid for no more than 18 months. It may end sooner if there's a change of HMRC's practice or a major version of the authorised software is released.

Solution

  1. In Onvio Centre, select Setup > Firm Settings from the menu bar. 
  2. Select the MTD tab. A table of your firm's authorisations is displayed. Each HMRC Reference Number needs its own authorisation if it's to be used in Onvio for MTD for VAT.

    Note: HMRC gave you an Agent Reference Number when you created your HMRC Agent Services Account.

  3. Make a note of the Agent Reference Number for the expired authorisation that you need to have reauthorised.
  4. Select the checkbox to the left of the expired authorisation, then Delete.
  5. Select Add from the toolbar.
  6. Enter the Agent Reference Number and a Description to identify the Agent Reference Number.
  7. Select Authorise.
  8. The HMRC portal is displayed. Log in using your HMRC Agent Services Account credentials.
  9. When the HMRC authorisation procedure is completed, select Done.
  10. Repeat this procedure for each Agent Reference Number that has an expired authorisation.

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