Filing accounts from Digita error: company/LLP not synchronized

Scenario

When trying to file accounts with Companies House from Digita Accounts Production Advanced via Onvio, you might see the following error message.

Error message

Unable to file because this company/LLP has not yet been synchronized with Onvio.

Causes

  1. The company/LLP has not been uplifted to Onvio and so does not have an Onvio Client ID and Onvio Contact ID.
  2. The company/LLP has been uplifted to Onvio but has not been updated in Digita Accounts Production Advanced.
  3. The company/LLP has been uplifted but there's no Onvio Client ID or Contact ID in Digita Practice Management.

Solutions

1. Not yet uplifted 

Before you start

  1. Make sure that you have installed Onvio Link on your device.
  2. Take the following steps to make sure that you have enabled Onvio Sync in Digita Practice Management.
    1. Log in to Digita Practice Management as administrator.
    2. Select Tools, Options, then Advanced Options.
    3. Select Onvio Sync, then Edit.
    4. Tick the Onvio Sync checkbox, then select OK.

Uplift the client to Onvio

  1. Right-click the client's name in Digita Practice Management, select Onvio, then Send to Onvio.
  2. Enter your Onvio Link login credentials if prompted to do so.
  3. Check that the Onvio Client ID and Onvio Contact ID field columns are shown in the Clients screen of Digita Practice Management. If not, select Field Chooser, then double-click these fields to add them. 
  4. Check that the Onvio Client ID and Onvio Contact ID are displayed for this client.
  5. Follow the instructions below to update Digita Accounts Production Advanced.

2. Uplifted but not updated in Digita Accounts Production Advanced

  1. Open the client in Digita Accounts Production Advanced.
  2. Select Integration at the bottom left, then Update client.

3. Uplifted but no Onvio Client ID or Contact ID in Digita Practice Management

  1. In Digita Practice Management, right-click on the client's name and select Onvio, then Unlink Onvio from the context menu.
  2. Right-click on the client's name again and select Onvio, then Send to Onvio from the context menu.
  3. Enter your credentials to log in to Onvio Link, if prompted to do so.
  4. In Onvio, select Setup, Utilities, then Migrations.
  5. If there is a conflict, resolve it by taking the steps in the Conflict resolution article.
  6. Restart Digita Practice Management and select Clients.
  7. Check that there's a tick in the Onvio column for the client.
  8. Select Integration at the bottom left to sync the new client IDs.

Note: Uplifting clients to Onvio can take 15 minutes or more after the progress dialog has closed.